Installation von openSUSE 13.1

Update oder Installation eines Betriebssystems sind immer ein Abenteuer. Starke Nebenwirkungen und sogar ein fataler Ausgang sind nicht ausgeschlossen. Während auf meinem zu Hause benutzten Rechner die Installation einer neuen Version von openSUSE zur Routine geworden ist, steht auf meinem Altrechner, den ich im Urlaub gelegentlich benutze, ein besonderer Härtefall an.

Der Rechner stellt ein kleines Computer-Museum dar. Er hat zwei Festplatten mit 80 und 200 GByte Kapazität, die in insgesamt fünfzehn Partitionen aufgeteilt sind. Darunter befinden sich mehrere bootfähige Systeme wie MSDOS 5.0, Windows 95, Windows 98, und openSUSE Versionen seit SuSE Linux 4.3. Seit dem Kauf meines ersten Rechners Anfang 1991 habe ich nichts weggeworfen, sondern alles aufgehoben. Den Rechner selbst habe ich 2003 aus Einzelteilen zusammengebaut, darunter befindet sich so ein altehrwürdiges Stück wie eine Matrox Millenium mit 8 MByte Videospeicher aus dem Jahr 1998.

Nach 6 Jahren problemlosen Betriebs schaffte ich in 2009 einen neuen Rechner an. Dessen Hauptplatine erwies aber als wesentlich weniger pflegeleicht als die seines Vorgängers. Ich war froh, dass ich diesen nur beiseite gestellt, nicht aber entsorgt hatte.

Usprünglich nutzte ich auf dem Zweitrechner SuSE Linux 10.0, das ich bei Gelegenheit auf die neuere Version openSUSE 11.2 umstellte. Als ich unter dieser Version meine vielen Fotos wieder anfasste, stellte sich heraus, dass einiges nicht mehr funktionierte und ein flüssiges Arbeiten nicht mehr möglich war.

Ich überlegte viele Möglichkeiten der Abhilfe und entschloss mich letztendlich für die einfachste, aber auch die riskanteste, nämlich die Installation von openSUSE 13.1. Diese Linux-Version entsprach meinen Vorstellungen am besten.

Da mein Rechner über einen Router mit dem Web verbunden ist, entschloss ich mich für eine Netzwerk-Installation. Ich brannte das Installationsprogramm auf eine gewöhnliche CD und bootete den Rechner von dieser. Die Installation über das Netzwerk dauerte meiner DSL-Verbindung entsprechend zwei Stunden und lief problemlos ab. Mit der Ein-Klick-Installation der KDE-Codecs ergänzte ich meine Installation.

Die Installation von openSUSE 13.1, der Updates sowie der Codecs lief ohne Fehlermeldungen ab, doch als der Rechner die grafische Oberfläche hochfuhr war die Enttäuschung groß. Das KDE-Desktop wurde nur unvollständig dargestellt und war nicht bedienbar.

Der Zugang durch die Hintertür über eine Systemverwalterkonsole zeigte das volle Ausmaß des Desasters: load average: 17, Cpu: 90% idle. Mit root-Rechten terminierte ich die Sitzung, benannte den Konfigurationsordner .kde4 um und loggte erneut ein. Dieses Mal konnte ich mit der Oberfläche arbeiten. Beim Start des Browsers fror die Oberfläche wieder ein. Ich entfernte die Datei für die Sitzungs-Wiederherstellung von Firefox, dann konnte ich endlich wie gewohnt den Rechner benutzen.

Die Feuerprobe steht allerdings noch bevor. Ich installiere jAlbum, das ich zur Präsentation meiner Fotos verwende. Entschlossen packe ich alle meine Fotos in ein Album, das während ich diesen Bericht schreibe, von jAlbum erstellt wird. Das dauert zwar, funktioniert aber ohne Probleme.

4. Januar:

Der Acrobat Reader ist nicht in der Distribution enthalten, kann aber herunter geladen und installiert werden:

zypper in AdbeRdr9.5.5-1_i486linux_enu.rpm

Ein Browser-Plugin wird von Adobe mitgeliefert, ist aber umständlich zu installieren und funktioniert z.B. nicht mit Opera. Empfehlenswerter ist mozplugger:

zypper in mozplugger-1.14.6-4.1.i586.rpm

Der in openSUSE enthaltene Flashplayer ist nicht die neueste Version, also:

rpm -e flash-player-11.2.202.332-22.1.i586
rpm -e flash-player-kde4-11.2.202.332-22.1.i586
rpm -i flash-plugin-11.2.202.332-release.i386.rpm

6. Januar: Für den Fortschritt müssen Opfer gebracht werden

Als ich in 2007 meine erste Digitalkamera kaufte war natürlich die bange Frage: wie würde SuSE Linux 10.0 damit umgehen? Überraschenderweise gab es überhaupt keine Probleme. Konqueror zeigte alle Bilder und Videos sofort eingebettet an, ohne dass an irgendwelchen Einstellungen gedreht werden musste. Digikam erkannte die Kamera als USB-Gerät, lud alle Files von der Kamera herunter und sortierte sie in Ordner entsprechend dem Aufnahmedatum ein. Auch dieses Programm stellte sowohl Bilder als auch Videos eingebettet dar ohne dass irgendwelche Einstellungen geändert werden mussten. Beide Programme reagierten ohne erkennbare Verzögerung auf das Anklicken.

Nach der Installation von openSUSE 13.1 gab es eine Überraschung: Digikam meldete beim Öffnen eines Quicktime Videos der Kamera: Dieses Bild kann nicht dargestellt werden. Nach einigem Suchen fand ich in den Einstellungen von Digikam unter „Dateizuordnungen > Zusätzliche Bilddateierweiterungen“ den Eintrag „mov“. Irgend ein Witzbold oder auch ein wohlmeinender, aber unbedarfter Zeitgenosse hatte diesen unnötigen Eintrag als Voreinstellung nach der Installation von Digikam vorgesehen. Ich entfernte den Eintrag und startete Digikam neu. Das Programm beharrte aber darauf, dass das Video ein Bild sei. Durch eine Suche im Web fand ich die Lösung: Digikam hatte die Einstellung in seine Datenbank eingetragen. Ich entfernte meine Bildersammlung aus Digikam und fügte die selben Bilder hinzu. Nach langem Arbeiten des Computers war die Datenbank neu erstellt und der Fehler behoben.

Doch es gab eine neue Überraschung: Beim Klick auf das Video stürzte Digikam blitzartig ab. Auch hier kam die Lösung aus dem Web: Phonon gstreamer crashing Digikam. Mit Phonon hatte ich explizit noch nichts zu tun. Nach diesem aufschlussreichen Hinweis installierte ich also das VLC-Backend und stellte unter „Systemeinstellungen > Hardware > Multimedia > Backend“ von GStreamer auf VLC um. Nun spielte Digikam das Video ab, allein es war nur der Ton zu hören, auf dem Bildschirm war nur ein schwarzes Rechteck zu sehen. Ich probierte einige Videoplayer aus. Insgesamt wurden vom System fünf verschiedene Player angeboten. Nur SMPlayer2 funktionierte einwandfrei, wurde aber vom System nicht wie früher eingebettet dargestellt, sondern in einem eigenen Fenster, was im Vergleich zur eingebetteten Darstellung ziemlich lang dauerte.

Auch zu diesem Problem gibt es einen hilfreichen Artikel: Enabling Thumbnails and Embedded Video in the Konqueror File Manager. Wie hier empfohlen suche ich in openSUSE 13.1 nach KMPlayer. Dieser Videoplayer fehlt allerdings in der Distribution. Im Netz gibt es jedoch ein Paket für openSUSE 13.1: KMplayer. Das Paket ist als instabil beschrieben. Ich installiere es trotzdem und probiere es in Konqueror. Dieser spielt das Video nun endlich wieder eingebettet ab, allerdings ist nur der Ton zu hören, statt des Films ist nur ein blaues Rechteck zu sehen.

Zu openSUSE 13.1 wurde bemerkt, dass endlich wieder einmal eine Linux-Distribution zum geplanten Termin fertig gestellt wurde. Das mag bemerkenswert sein, allerdings mussten bei der Funktionalität gegenüber SuSE Linux 10.0 wie oben beschrieben Abstriche gemacht werden.

Über Karl

Ich bin Physiker im Ruhestand
Dieser Beitrag wurde unter Computer abgelegt und mit , , , , , , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

6 Antworten zu Installation von openSUSE 13.1

  1. ThomasG schreibt:

    Da hat sich bei Dir in letzter Zeit aber ganz schön was getan Karl🙂. Nicht nur, dass Du in letzter Zeit einen Haufen Fotos ins Netz gestellt hast, nein jetzt bastelst Du auch noch kräftig an Deinem Rechner herum. 1994 oder 1995 habe ich mir glaube ich meinen ersten PC gekauft. Ende 2003 dann einen anderen inklusive Internetzugang. Tja – und der hat dann glaube ich 2008 schlapp gemacht. Und somit sitze ich gerade vor meinem vierten Rechner. Auch ich habe die ausgedienten Rechner bis heute nicht weggeworfen. Was Du da angestellt hast, würde ich ja auch gerne können, aber dazu habe ich wohl viel zu wenig Ahnung von der Sache. Früher habe ich mich für Computer überhaupt nicht interessiert. So kann`s kommen und jetzt hocke ich den halben Tag vor so einem blöden Ding😉. Hoffentlich hält meine Kiste noch ein Weilchen durch. Momentan könnte ich mir keinen neuen Rechner leisten.

    • Karl schreibt:

      Wenn Dein Rechner nicht mehr mag kaufst Du auf dem Flohmarkt für weniger als 100€ einen neuen und installierst darauf die neueste Version von Linux. Windows 8 ließe sich auf meinem Rechner nicht installieren, openSUSE 13.1 läuft dagegen einwandfrei.

  2. ThomasG schreibt:

    Da habe ich glatt vergessen Dir ein gutes neues Jahr zu wünschen Karl, was ich hiermit nachhole. Ich hoffe natürlich, dass meine Mühle es noch ein Weilchen macht, aber Deine Tips habe ich bereits fest abgespeichert und ich weiß ja auch, wo ich nachschauen muss, falls ich unsicher bin, ob ich alles richtig behalten habe🙂.

  3. Pingback: Migration zu KMail2 | Karl Mistelberger

  4. Pingback: Entwicklung der Hardware meines PC | Karl Mistelberger

Schreibe einen Kommentar

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s